liblogging-1.0.5.ebuild 735 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils eutils
  5. DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
  6. HOMEPAGE="http://www.liblogging.org"
  7. SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0/0"
  10. KEYWORDS="amd64 arm ~arm64 hppa x86"
  11. IUSE="rfc3195 static-libs +stdlog systemd"
  12. RDEPEND="systemd? ( sys-apps/systemd )"
  13. DEPEND="
  14. ${RDEPEND}
  15. virtual/pkgconfig
  16. "
  17. DOCS=( ChangeLog )
  18. AUTOTOOLS_IN_SOURCE_BUILD=1
  19. src_configure() {
  20. local myeconfargs=(
  21. $(use_enable rfc3195)
  22. $(use_enable stdlog)
  23. $(use_enable systemd journal)
  24. )
  25. autotools-utils_src_configure
  26. }