1234567891011121314151617181920212223242526272829303132333435 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="6"
- inherit ltprune
- DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
- HOMEPAGE="https://github.com/opensc/libp11/wiki"
- SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
- LICENSE="LGPL-2.1"
- SLOT="0"
- KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
- IUSE="libressl bindist doc static-libs"
- RDEPEND="
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )"
- DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
- src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable doc api-doc)
- }
- src_install() {
- default
- prune_libtool_files --all
- }
|