libp11-0.4.4.ebuild 782 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit ltprune
  5. DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
  6. HOMEPAGE="https://github.com/opensc/libp11/wiki"
  7. SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
  11. IUSE="libressl bindist doc static-libs"
  12. RDEPEND="
  13. !libressl? ( dev-libs/openssl:0=[bindist=] )
  14. libressl? ( dev-libs/libressl:0= )"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. doc? ( app-doc/doxygen )"
  18. src_configure() {
  19. econf \
  20. --enable-shared \
  21. $(use_enable static-libs static) \
  22. $(use_enable doc api-doc)
  23. }
  24. src_install() {
  25. default
  26. prune_libtool_files --all
  27. }