1234567891011121314151617181920212223242526272829303132333435363738 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils flag-o-matic multilib
- DESCRIPTION="Library for easy processing of keyboard entry from terminal-based programs"
- HOMEPAGE="http://www.leonerd.org.uk/code/libtermkey/"
- SRC_URI="http://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE="demos"
- RDEPEND="dev-libs/unibilium:="
- DEPEND="${RDEPEND}
- sys-devel/libtool
- virtual/pkgconfig
- demos? ( dev-libs/glib:2 )"
- src_prepare() {
- if ! use demos; then
- sed -e '/^all:/s:$(DEMOS)::' -i Makefile || die
- fi
- }
- src_compile() {
- append-flags -fPIC -fPIE
- emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
- }
- src_install() {
- emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- DESTDIR="${D}" install
- prune_libtool_files
- }
|