libtermkey-0.17.ebuild 882 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic multilib
  5. DESCRIPTION="Library for easy processing of keyboard entry from terminal-based programs"
  6. HOMEPAGE="http://www.leonerd.org.uk/code/libtermkey/"
  7. SRC_URI="http://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="demos"
  12. RDEPEND="dev-libs/unibilium:="
  13. DEPEND="${RDEPEND}
  14. sys-devel/libtool
  15. virtual/pkgconfig
  16. demos? ( dev-libs/glib:2 )"
  17. src_prepare() {
  18. if ! use demos; then
  19. sed -e '/^all:/s:$(DEMOS)::' -i Makefile || die
  20. fi
  21. }
  22. src_compile() {
  23. append-flags -fPIC -fPIE
  24. emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
  25. }
  26. src_install() {
  27. emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
  28. DESTDIR="${D}" install
  29. prune_libtool_files
  30. }