12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit autotools eutils
- DESCRIPTION="A high-performance MongoDB driver for C"
- HOMEPAGE="https://github.com/mongodb/mongo-c-driver"
- SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="~amd64 ~hppa ~x86"
- IUSE="debug examples libressl sasl ssl static-libs test"
- RDEPEND=">=dev-libs/libbson-1.3.5
- sasl? ( dev-libs/cyrus-sasl )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
- DEPEND="${RDEPEND}
- test? ( dev-db/mongodb )"
- DOCS=( NEWS README.rst )
- src_prepare() {
- rm -r src/libbson || die
- sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
- # https://github.com/mongodb/mongo-c-driver/issues/54
- sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/Makefile.am \
- tests/Makefile.am || die
- eautoreconf
- }
- src_configure() {
- econf --with-libbson=system \
- --disable-hardening \
- --disable-optimizations \
- --disable-examples \
- --docdir="${EPREFIX}/usr/share/doc/${P}" \
- $(use_enable sasl) \
- $(use_enable ssl ssl openssl) \
- $(use_enable debug) \
- $(use_enable static-libs static)
- }
- src_install() {
- default_src_install
- if [[ -f "${D}usr/share/doc/${P}/COPYING" ]] ; then
- rm "${D}usr/share/doc/${P}/COPYING" || die
- fi
- # Only install the mongoc man pages to avoid conflicts of common names
- doman doc/man/mongoc_*.3
- use static-libs || find "${D}" -name '*.la' -delete
- if use examples; then
- insinto /usr/share/${PF}/examples
- doins -r examples/*.c examples/aggregation examples/bulk
- fi
- }
- src_test() {
- # Avoid allocating too much disk space by using server.smallFiles = 1
- echo -e "storage:\n smallFiles: true" > "${T}/mongod.conf"
- local PORT=27099
- mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
- -f "${T}/mongod.conf" --dbpath="${T}" \
- --logpath="${T}/mongod.log" || die
- MONGOC_TEST_HOST="127.0.0.1:${PORT}" emake test
- kill `cat "${T}/mongod.lock"`
- }
|