papi-5.3.0.ebuild 772 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. inherit autotools-utils fortran-2 versionator
  6. DESCRIPTION="Performance Application Programming Interface"
  7. HOMEPAGE="http://icl.cs.utk.edu/papi/"
  8. SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="static-libs"
  13. DEPEND="
  14. dev-libs/libpfm[static-libs]
  15. virtual/mpi
  16. "
  17. RDEPEND="${DEPEND}"
  18. S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
  19. src_configure() {
  20. local myeconfargs=(
  21. --with-shlib
  22. --with-perf-events
  23. --with-pfm-prefix="${EPREFIX}/usr"
  24. )
  25. autotools-utils_src_configure
  26. }
  27. src_install() {
  28. autotools-utils_src_install
  29. dodoc ../RE*
  30. }