pegtl-1.3.1-r1.ebuild 631 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="header-only library for creating parsers according to Parsing Expression Grammar"
  6. HOMEPAGE="https://github.com/ColinH/PEGTL"
  7. SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="test"
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. S="${WORKDIR}/PEGTL-${PV}"
  15. src_compile() {
  16. :
  17. }
  18. src_test() {
  19. emake CXX="$(tc-getCXX)" PEGTL_CXXFLAGS="${CXXFLAGS}"
  20. }
  21. src_install() {
  22. dodoc README.md
  23. insinto /usr/include
  24. doins -r pegtl pegtl.hh
  25. }