spdlog-0.13.0.ebuild 655 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Very fast, header only, C++ logging library."
  6. HOMEPAGE="https://github.com/gabime/spdlog"
  7. if [[ ${PV} == *9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/gabime/spdlog"
  10. else
  11. SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="~amd64"
  13. fi
  14. LICENSE="MIT"
  15. SLOT="0"
  16. IUSE="test"
  17. DEPEND=""
  18. RDEPEND="${DEPEND}"
  19. src_configure() {
  20. local mycmakeargs=(
  21. -DSPDLOG_BUILD_EXAMPLES=no
  22. -DSPDLOG_BUILD_TESTING=$(usex test)
  23. )
  24. cmake-utils_src_configure
  25. }