cppo-1.4.1.ebuild 695 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit findlib
  5. DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
  6. HOMEPAGE="http://mjambon.com/cppo.html"
  7. SRC_URI="https://github.com/mjambon/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. SLOT="0/${PV}"
  9. LICENSE="BSD"
  10. KEYWORDS="amd64 ~arm ppc x86"
  11. IUSE="examples"
  12. RDEPEND=">=dev-lang/ocaml-3.12:=
  13. dev-ml/ocamlbuild:="
  14. DEPEND="${RDEPEND}"
  15. src_install() {
  16. findlib_src_preinst
  17. mkdir -p "${ED}"/usr/bin
  18. emake PREFIX="${ED}"/usr install
  19. dodoc README.md Changes
  20. if use examples ; then
  21. dodoc -r examples
  22. docompress -x /usr/share/doc/${PF}/examples
  23. fi
  24. }