ocamlbuild-0.10.1.ebuild 1003 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
  5. HOMEPAGE="https://github.com/ocaml/ocamlbuild"
  6. SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="LGPL-2.1-with-linking-exception"
  8. SLOT="0/${PV}"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
  10. IUSE="+ocamlopt"
  11. DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
  12. RDEPEND="${DEPEND}
  13. !<dev-ml/findlib-1.6.1-r1
  14. "
  15. src_configure() {
  16. emake -f configure.make Makefile.config \
  17. PREFIX="${EPREFIX}/usr" \
  18. BINDIR="${EPREFIX}/usr/bin" \
  19. LIBDIR="$(ocamlc -where)" \
  20. OCAML_NATIVE=$(usex ocamlopt true false) \
  21. OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
  22. NATDYNLINK=$(usex ocamlopt true false)
  23. }
  24. src_install() {
  25. emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
  26. dodoc Changes
  27. }