PEAR-Net_SMTP-1.7.3.ebuild 700 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="${PN/PEAR-/}"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="A PHP implementation of the SMTP protocol"
  7. HOMEPAGE="http://pear.php.net/package/${MY_PN}"
  8. SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
  9. LICENSE="PHP-3.01"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
  12. IUSE="examples sasl"
  13. DEPEND=""
  14. RDEPEND="dev-lang/php:*
  15. dev-php/PEAR-Net_Socket
  16. dev-php/PEAR-PEAR
  17. sasl? ( dev-php/PEAR-Auth_SASL )"
  18. S="${WORKDIR}/${MY_P}"
  19. src_install() {
  20. dodoc docs/guide.txt
  21. use examples && dodoc -r examples
  22. insinto /usr/share/php
  23. doins -r Net
  24. }