pecl-http-2.6.0-r1.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PHP_EXT_NAME="http"
  5. PHP_EXT_PECL_PKG="pecl_http"
  6. PHP_EXT_INI="yes"
  7. PHP_EXT_ZENDEXT="no"
  8. USE_PHP="php5-6 php7-0 php7-1"
  9. inherit php-ext-pecl-r3
  10. USE_PHP="php5-6"
  11. KEYWORDS="~amd64 ~x86"
  12. DESCRIPTION="Extended HTTP Support for PHP"
  13. LICENSE="BSD-2 MIT"
  14. SLOT="2"
  15. IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
  16. DEPEND="php_targets_php5-6? (
  17. dev-libs/libevent
  18. dev-php/pecl-propro:0[php_targets_php5-6]
  19. dev-php/pecl-raphf:0[php_targets_php5-6]
  20. net-dns/libidn
  21. sys-libs/zlib
  22. ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
  23. !ssl? ( net-misc/curl[-ssl] )
  24. dev-lang/php:5.6[hash,session,iconv] )"
  25. RDEPEND="${DEPEND}"
  26. PDEPEND="
  27. php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
  28. php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )"
  29. PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
  30. src_prepare() {
  31. if use php_targets_php5-6 ; then
  32. php-ext-source-r3_src_prepare
  33. else
  34. default_src_prepare
  35. fi
  36. }
  37. src_install() {
  38. if use php_targets_php5-6 ; then
  39. php-ext-pecl-r3_src_install
  40. # Ensure that the http extension is loaded after its
  41. # dependencies raphf and propro (bug 612054). Some day
  42. # this should be possible through the eclass (bug 586446).
  43. local slot, file, oldname, newname
  44. for slot in $(php_get_slots); do
  45. php_init_slot_env "${slot}"
  46. for file in $(php_slot_ini_files "${slot}") ; do
  47. # Prepend "zz" to the ini symlink name. This is sadly
  48. # coupled to the naming convention in the eclass.
  49. oldname="${ED}/${file/ext/ext-active}"
  50. newname="${oldname/${PHP_EXT_NAME}.ini/zz${PHP_EXT_NAME}.ini}"
  51. mv "${oldname}" "${newname}" \
  52. || die "failed to rename ${oldname} to ${newname}"
  53. einfo "renamed ${oldname} to ${newname}"
  54. done
  55. done
  56. fi
  57. }