pecl-http-3.1.0.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PHP_EXT_NAME="http"
  5. PHP_EXT_PECL_PKG="pecl_http"
  6. PHP_EXT_INI="yes"
  7. PHP_EXT_ZENDEXT="no"
  8. USE_PHP="php5-6 php7-0 php7-1"
  9. inherit php-ext-pecl-r3
  10. USE_PHP="php7-0 php7-1"
  11. KEYWORDS="amd64 x86"
  12. DESCRIPTION="Extended HTTP Support for PHP"
  13. LICENSE="BSD-2 MIT"
  14. SLOT="7"
  15. IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
  16. DEPEND="dev-libs/libevent
  17. dev-php/pecl-propro:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?]
  18. dev-php/pecl-raphf:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?]
  19. net-dns/libidn
  20. sys-libs/zlib
  21. ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
  22. !ssl? ( net-misc/curl[-ssl] )
  23. php_targets_php7-0? ( dev-lang/php:7.0[hash,session,iconv] )
  24. php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )"
  25. RDEPEND="${DEPEND}
  26. php_targets_php5-6? ( dev-php/pecl-http:2[php_targets_php5-6] )"
  27. PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
  28. PATCHES=( "${FILESDIR}/pecl-http-gnutls.patch" )
  29. src_prepare() {
  30. if use php_targets_php7-0 || use php_targets_php7-1 ; then
  31. php-ext-source-r3_src_prepare
  32. else
  33. default_src_prepare
  34. fi
  35. }
  36. src_install() {
  37. if use php_targets_php7-0 || use php_targets_php7-1 ; then
  38. php-ext-pecl-r3_src_install
  39. fi
  40. }
  41. pkg_postinst() {
  42. ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
  43. ewarn "Please review the documentation and update your code."
  44. }