tcpdf-6.2.13-r1.ebuild 1002 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
  5. HOMEPAGE="http://www.tcpdf.org/"
  6. SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
  7. -> ${P}.tar.gz"
  8. # Main source is LGPL-3+, some included fonts have other licenses
  9. LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="examples"
  13. RDEPEND="dev-lang/php"
  14. S="${WORKDIR}/${P^^}"
  15. src_install() {
  16. insinto /etc
  17. doins config/tcpdf_config.php
  18. # Create a symlink for the config file, because the library will only
  19. # look for it in its own source tree (not in /etc where we've put it).
  20. dosym /etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
  21. exeinto "/usr/share/php/${PN}/tools"
  22. doexe tools/tcpdf_addfont.php
  23. insinto "/usr/share/php/${PN}"
  24. doins tcpdf*.php
  25. doins -r include fonts
  26. dodoc CHANGELOG.TXT README.md
  27. use examples && dodoc -r examples
  28. }