texpower-0.2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit latex-package
  4. IUSE="doc"
  5. MY_P="${P/./-}"
  6. DESCRIPTION="A bundle of style and class files for creating dynamic online presentations"
  7. SRC_URI="mirror://sourceforge/texpower/${MY_P}.tar.gz"
  8. HOMEPAGE="http://texpower.sourceforge.net/"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc sparc x86"
  12. S="${WORKDIR}/${MY_P}"
  13. src_compile() {
  14. latex-package_src_compile
  15. cd tpslifonts
  16. latex-package_src_compile
  17. cp tpslifonts.sty ../ || die
  18. cd ../
  19. if use doc
  20. then
  21. for file in FAQ-display.tex FAQ-printout.tex fulldemo.tex
  22. do
  23. einfo "Making documentation: ${file}"
  24. VARTEXFONTS=${T}/fonts texi2pdf -q -c \
  25. --language=latex ${file} &> /dev/null
  26. done
  27. fi
  28. }
  29. src_install() {
  30. latex-package_src_doinstall styles pdf
  31. insinto /usr/share/texmf/tex/latex/${PN}/contrib
  32. doins contrib/config.landscapeplus contrib/tpmultiinc.tar || die
  33. dodoc 00readme.txt 01install.txt || die
  34. newdoc tpslifonts/00readme.txt 00readme-tpslifonts.txt || die
  35. newdoc contrib/00readme.txt 00readme-contrib.txt
  36. }