git-bzr-ng-0_pre20120822-r2.ebuild 724 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
  7. HOMEPAGE="https://github.com/termie/git-bzr-ng"
  8. SRC_URI="https://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="
  15. >=dev-vcs/bzr-2.2
  16. dev-vcs/git
  17. >=dev-vcs/bzr-fastimport-0.10
  18. ${PYTHON_DEPS}"
  19. DEPEND="app-arch/xz-utils"
  20. src_prepare() {
  21. default
  22. python_fix_shebang git-bzr
  23. }
  24. src_install() {
  25. exeinto /usr/libexec/git-core
  26. doexe git-bzr
  27. dodoc README.rst
  28. }