hgsubversion-1.8.5.ebuild 974 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
  7. HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.python.org/pypi/hgsubversion"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos ~x86-solaris"
  12. IUSE="test"
  13. # although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
  14. RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
  15. dev-vcs/mercurial[${PYTHON_USEDEP}]
  16. || (
  17. >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
  18. >=dev-vcs/subversion-1.5[python] )"
  19. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
  20. test? ( dev-python/nose[${PYTHON_USEDEP}] )"
  21. DOCS=( README )
  22. #python_test() {
  23. # "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
  24. #}