qbzr-0.23.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1 versionator
  6. DESCRIPTION="Qt frontend for Bazaar"
  7. HOMEPAGE="https://launchpad.net/qbzr"
  8. SRC_URI="https://edge.launchpad.net/qbzr/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ppc x86"
  12. IUSE=""
  13. # bzr version comes from NEWS file. It's lowest version required for some
  14. # features to work.
  15. DEPEND=">=dev-vcs/bzr-2.5
  16. >=dev-python/PyQt4-4.1[X]"
  17. RDEPEND="${DEPEND}"
  18. S="${WORKDIR}/${PN}"
  19. DOCS=( AUTHORS.txt NEWS.txt README.txt TODO.txt )
  20. src_test() {
  21. elog "It's impossible to run tests at this point. If you wish to run tests"
  22. elog "after installation of ${PN} execute:"
  23. elog " $ bzr selftest -s bzrlib.plugins.qbzr"
  24. }
  25. pkg_postinst() {
  26. elog
  27. elog "To enable spellchecking in qcommit, please, install >=dev-python/pyenchant-1.5.0"
  28. elog " # emerge -a >=dev-python/pyenchant-1.5.0"
  29. elog "To enable syntax highlighting, please, install dev-python/pygments"
  30. elog " # emerge -a dev-python/pygments"
  31. }