barrage-1.0.4.ebuild 663 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="A violent point-and-click shooting game"
  6. HOMEPAGE="http://lgames.sourceforge.net"
  7. SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND=">=media-libs/libsdl-1.2[sound,video]
  13. >=media-libs/sdl-mixer-1.2.4"
  14. RDEPEND="${DEPEND}"
  15. src_configure() {
  16. egamesconf --datadir="${GAMES_DATADIR_BASE}"
  17. }
  18. src_install() {
  19. default
  20. newicon barrage48.png ${PN}.png
  21. make_desktop_entry ${PN} Barrage
  22. rm "${D}"/usr/share/applications/${PN}.desktop
  23. prepgamesdirs
  24. }