transcend-0.3-r1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Retro-style, abstract, 2D shooter"
  6. HOMEPAGE="http://transcend.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/Transcend_${PV}_UnixSource.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. DEPEND="
  13. media-libs/freeglut
  14. media-libs/portaudio
  15. x11-libs/libXi
  16. x11-libs/libXmu
  17. virtual/glu
  18. virtual/opengl"
  19. RDEPEND=${DEPEND}
  20. S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
  21. # Apply patch from Debian in order to get sound working. bug #372413
  22. PATCHES=(
  23. "${FILESDIR}"/${P}-sound.patch
  24. )
  25. src_prepare() {
  26. default
  27. rm -rf game/Makefile portaudio/ || die
  28. sed \
  29. -e '/^GXX=/d' \
  30. -e 's/GXX/CXX/' \
  31. -e '/^COMPILE_FLAGS =/ s/OPTIMIZE_FLAG/CXXFLAGS/' \
  32. -e '/^EXE_LINK =/ s/LINK_FLAGS/LDFLAGS/' \
  33. Makefile.GnuLinuxX86 \
  34. Makefile.common \
  35. Makefile.minorGems \
  36. game/Makefile.all \
  37. Makefile.minorGems_targets \
  38. > game/Makefile || die
  39. sed -i \
  40. -e "s:\"levels\":\"/usr/share/${PN}/levels\":" \
  41. game/LevelDirectoryManager.cpp \
  42. game/game.cpp || die
  43. }
  44. src_configure() { :; }
  45. src_compile() {
  46. emake -C game
  47. }
  48. src_install() {
  49. newbin game/Transcend ${PN}
  50. insinto /usr/share/${PN}
  51. doins -r levels/
  52. dodoc doc/{how_to_play.txt,changeLog.txt}
  53. make_desktop_entry ${PN} "Transcend"
  54. }