marbleblast-demo-1.3.ebuild 817 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit unpacker games
  5. DESCRIPTION="race marbles through crazy stages"
  6. HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=3"
  7. SRC_URI="ftp://ggdev-1.homelan.com/marbleblast/MarbleBlastDemo-${PV}.sh.bin"
  8. LICENSE="MARBLEBLAST"
  9. SLOT="0"
  10. KEYWORDS="-* ~amd64 x86"
  11. IUSE=""
  12. RESTRICT="strip"
  13. S=${WORKDIR}
  14. dir=${GAMES_PREFIX_OPT}/${PN}
  15. QA_PREBUILT="${dir:1}/marbleblastdemo.bin
  16. ${dir:1}/lib/lib*"
  17. src_install() {
  18. dodir "${dir}" "${GAMES_BINDIR}"
  19. tar -zxf MarbleBlast.tar.gz -C "${D}/${dir}" || die "extracting MarbleBlast.tar.gz"
  20. exeinto "${dir}"
  21. doexe bin/Linux/x86/marbleblastdemo
  22. dosym "${dir}"/marbleblastdemo "${GAMES_BINDIR}"/marbleblast-demo
  23. dodoc README_DEMO.txt
  24. prepgamesdirs
  25. }