ccgo-0.3.6.5.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils toolchain-funcs flag-o-matic games
  5. DESCRIPTION="An IGS client written in C++"
  6. HOMEPAGE="http://ccdw.org/~cjj/prog/ccgo/"
  7. SRC_URI="http://ccdw.org/~cjj/prog/ccgo/src/${P}.tar.gz"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE="nls"
  12. RDEPEND=">=dev-cpp/gtkmm-2.4:2.4
  13. >=dev-cpp/gconfmm-2.6
  14. nls? ( virtual/libintl )"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. nls? ( sys-devel/gettext )"
  18. src_prepare() {
  19. sed -i \
  20. -e '/^Encoding/d' \
  21. -e '/^Categories/ { s/Application;//; s/$/GTK;/ }' \
  22. ccgo.desktop.in || die
  23. sed -i \
  24. -e '/^localedir/s/=.*/=@localedir@/' \
  25. -e '/^appicondir/s:=.*:=/usr/share/pixmaps:' \
  26. -e '/^desktopdir/s:=.*:=/usr/share/applications:' \
  27. Makefile.am || die
  28. # cargo cult from bug #569528
  29. append-cxxflags -std=c++11 -fpermissive
  30. find . -name '*.hh' -exec sed -i -e '/sigc++\/object.h/d' {} +
  31. find . -name '*.cc' -exec sed -i -e 's/(bind(/(sigc::bind(/' {} +
  32. epatch "${FILESDIR}"/${P}-gcc4.patch
  33. eautoreconf
  34. }
  35. src_configure() {
  36. egamesconf \
  37. --localedir=/usr/share/locale \
  38. $(use_enable nls)
  39. }
  40. src_compile() {
  41. emake AR="$(tc-getAR)"
  42. }
  43. src_install() {
  44. default
  45. prepgamesdirs
  46. }