tetzle-2.0.3.ebuild 972 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit qt4-r2 gnome2-utils games
  5. DESCRIPTION="A jigsaw puzzle game that uses tetrominoes for the pieces"
  6. HOMEPAGE="http://gottcode.org/tetzle/"
  7. SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND=">=dev-qt/qtgui-4.7:4
  13. >=dev-qt/qtopengl-4.7:4"
  14. RDEPEND="${DEPEND}"
  15. DOCS="ChangeLog CREDITS"
  16. src_prepare() {
  17. sed -i \
  18. -e "s:appdir + \"/../share/\":\"${GAMES_DATADIR}/\":" \
  19. src/locale_dialog.cpp || die
  20. sed -i \
  21. -e "/qm.path/s:\$\$PREFIX/share:${GAMES_DATADIR}:" \
  22. ${PN}.pro || die
  23. }
  24. src_configure() {
  25. eqmake4 BINDIR="${GAMES_BINDIR/\/usr}" PREFIX="/usr"
  26. }
  27. src_install() {
  28. qt4-r2_src_install
  29. prepgamesdirs
  30. }
  31. pkg_preinst() {
  32. games_pkg_preinst
  33. gnome2_icon_savelist
  34. }
  35. pkg_postinst() {
  36. games_pkg_postinst
  37. gnome2_icon_cache_update
  38. }
  39. pkg_postrm() {
  40. gnome2_icon_cache_update
  41. }