lmarbles-1.0.8.ebuild 733 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils games
  5. DESCRIPTION="puzzle game inspired by Atomix and written in SDL"
  6. HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LMarbles"
  7. SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="media-libs/libsdl[video]
  13. media-libs/sdl-mixer"
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. mv configure.{in,ac}
  17. rm *.m4
  18. epatch "${FILESDIR}"/${P}-gentoo.patch
  19. eautoreconf
  20. }
  21. src_install() {
  22. default
  23. newicon lmarbles48.gif ${PN}.gif
  24. make_desktop_entry lmarbles LMarbles /usr/share/pixmaps/${PN}.gif
  25. dohtml src/manual/*
  26. prepgamesdirs
  27. }