mindless-1.6.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. ORANAME="OracleAll_050523.txt"
  6. DESCRIPTION="play collectable/trading card games (Magic: the Gathering and possibly others) against other people"
  7. HOMEPAGE="http://mindless.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/mindless/${P}.tar.gz
  9. http://www.wizards.com/dci/oracle/${ORANAME}"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ppc x86"
  13. IUSE=""
  14. RESTRICT="mirror" # for the card database
  15. RDEPEND="x11-libs/gtk+:2
  16. media-fonts/font-schumacher-misc"
  17. DEPEND="${RDEPEND}
  18. gnome-base/librsvg
  19. virtual/pkgconfig"
  20. src_unpack() {
  21. unpack "${P}.tar.gz"
  22. cp "${DISTDIR}/${ORANAME}" "${WORKDIR}" || die "cp failed"
  23. DATAFILE="${GAMES_DATADIR}/${PN}/${ORANAME}"
  24. }
  25. src_prepare() {
  26. sed -i \
  27. -e '/^CC=/d' \
  28. -e '/^CFLAGS=/d' \
  29. Makefile \
  30. || die 'sed failed'
  31. }
  32. src_install() {
  33. dogamesbin mindless
  34. insinto "${GAMES_DATADIR}/${PN}"
  35. doins "${WORKDIR}/${ORANAME}"
  36. dodoc CHANGES README TODO
  37. prepgamesdirs
  38. }
  39. pkg_postinst() {
  40. games_pkg_postinst
  41. echo
  42. elog "The first time you start ${PN} you need to tell it where to find"
  43. elog "the text database of cards. This file has been installed at:"
  44. elog "${DATAFILE}"
  45. echo
  46. }