crashtest-1.1.ebuild 844 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic games
  5. DESCRIPTION="Educational car crash simulator"
  6. HOMEPAGE="http://www.stolk.org/crashtest/"
  7. SRC_URI="http://www.stolk.org/crashtest/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="
  13. x11-libs/fltk:1[opengl]
  14. dev-games/ode
  15. media-libs/alsa-lib
  16. virtual/opengl
  17. virtual/glu
  18. media-libs/freeglut"
  19. DEPEND="${RDEPEND}
  20. >=media-libs/plib-1.8.4"
  21. S=${WORKDIR}/${P}/src-${PN}
  22. src_prepare() {
  23. epatch "${FILESDIR}/${P}"-gentoo.patch
  24. sed -i \
  25. -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
  26. -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
  27. Makefile ${PN}.cxx || die
  28. append-flags -DHAVE_ISNANF
  29. }
  30. src_install() {
  31. default
  32. make_desktop_entry ${PN} Crashtest
  33. prepgamesdirs
  34. }