cjs-2.8.0.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. inherit autotools eutils gnome2 pax-utils virtualx
  6. DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
  7. HOMEPAGE="http://cinnamon.linuxmint.com/"
  8. SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
  10. SLOT="0"
  11. IUSE="+cairo examples gtk test"
  12. KEYWORDS="amd64 x86"
  13. RDEPEND="
  14. dev-lang/spidermonkey:24
  15. >=dev-libs/glib-2.37.3:2
  16. >=dev-libs/gobject-introspection-1.38:=
  17. sys-libs/readline:0
  18. virtual/libffi
  19. cairo? ( x11-libs/cairo[X,glib] )
  20. gtk? ( x11-libs/gtk+:3 )
  21. "
  22. DEPEND="${RDEPEND}
  23. gnome-base/gnome-common
  24. sys-devel/gettext
  25. virtual/pkgconfig
  26. test? ( sys-apps/dbus )
  27. "
  28. # Cinnamon 2.2 does not work with this release.
  29. RDEPEND="${RDEPEND}
  30. !<gnome-extra/cinnamon-2.4
  31. "
  32. src_prepare() {
  33. # Disable broken unittests
  34. epatch "${FILESDIR}"/${PN}-2.4.0-disable-unittest-*.patch
  35. epatch_user
  36. eautoreconf
  37. gnome2_src_prepare
  38. }
  39. src_configure() {
  40. # FIXME: add systemtap/dtrace support, like in glib:2
  41. # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
  42. # XXX: Do NOT enable coverage, completely useless for portage installs
  43. gnome2_src_configure \
  44. --disable-systemtap \
  45. --disable-dtrace \
  46. --disable-coverage \
  47. $(use_with cairo) \
  48. $(use_with gtk)
  49. }
  50. src_test() {
  51. Xemake check
  52. }
  53. src_install() {
  54. # installation sometimes fails in parallel
  55. gnome2_src_install -j1
  56. if use examples; then
  57. insinto /usr/share/doc/"${PF}"/examples
  58. doins "${S}"/examples/*
  59. fi
  60. # Required for cjs-console to run correctly on PaX systems
  61. pax-mark mr "${ED}/usr/bin/cjs-console"
  62. }