cjs-3.2.0.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools gnome2 pax-utils virtualx
  5. DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
  6. HOMEPAGE="http://cinnamon.linuxmint.com/"
  7. SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
  9. SLOT="0"
  10. IUSE="+cairo examples gtk test"
  11. KEYWORDS="~amd64 ~x86"
  12. RDEPEND="
  13. dev-lang/spidermonkey:24
  14. >=dev-libs/glib-2.37.3:2
  15. >=dev-libs/gobject-introspection-1.38:=
  16. sys-libs/readline:0
  17. virtual/libffi
  18. cairo? ( x11-libs/cairo[X,glib] )
  19. gtk? ( x11-libs/gtk+:3 )
  20. "
  21. DEPEND="${RDEPEND}
  22. gnome-base/gnome-common
  23. sys-devel/gettext
  24. virtual/pkgconfig
  25. test? ( sys-apps/dbus )
  26. "
  27. # Cinnamon 2.2 does not work with this release.
  28. RDEPEND="${RDEPEND}
  29. !<gnome-extra/cinnamon-2.4
  30. "
  31. src_prepare() {
  32. # Disable broken unittests
  33. eapply "${FILESDIR}"/${PN}-2.4.0-disable-unittest-*.patch
  34. eautoreconf
  35. gnome2_src_prepare
  36. }
  37. src_configure() {
  38. # FIXME: add systemtap/dtrace support, like in glib:2
  39. # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
  40. # XXX: Do NOT enable coverage, completely useless for portage installs
  41. gnome2_src_configure \
  42. --disable-systemtap \
  43. --disable-dtrace \
  44. --disable-coverage \
  45. $(use_with cairo) \
  46. $(use_with gtk)
  47. }
  48. src_test() {
  49. virtx emake check
  50. }
  51. src_install() {
  52. # installation sometimes fails in parallel
  53. gnome2_src_install -j1
  54. if use examples; then
  55. insinto /usr/share/doc/"${PF}"/examples
  56. doins "${S}"/examples/*
  57. fi
  58. # Required for cjs-console to run correctly on PaX systems
  59. pax-mark mr "${ED}/usr/bin/cjs-console"
  60. }