gnome-characters-3.22.0.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VALA_USE_DEPEND="vapigen"
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit gnome2 python-any-r1 vala virtualx
  7. DESCRIPTION="Unicode character map viewer and library"
  8. HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
  9. LICENSE="GPL-2 BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="test"
  13. RDEPEND="
  14. >=dev-libs/gjs-1.43.3
  15. >=dev-libs/glib-2.32:2
  16. >=dev-libs/gobject-introspection-1.35.9:=
  17. >=dev-libs/libunistring-0.9.5
  18. >=x11-libs/gtk+-3.20:3[introspection]
  19. >=x11-libs/pango-1.36[introspection]
  20. "
  21. DEPEND="${RDEPEND}
  22. dev-libs/appstream-glib
  23. >=sys-devel/gettext-0.19.8
  24. virtual/pkgconfig
  25. test? (
  26. ${PYTHON_DEPS}
  27. $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
  28. "
  29. python_check_deps() {
  30. use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
  31. }
  32. pkg_setup() {
  33. use test && python-any-r1_pkg_setup
  34. }
  35. src_prepare() {
  36. gnome2_src_prepare
  37. vala_src_prepare
  38. }
  39. src_configure() {
  40. gnome2_src_configure $(use_enable test dogtail)
  41. }
  42. src_test() {
  43. virtx emake check
  44. }