kaddressbook-4.14.11_pre20160211.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_HANDBOOK="optional"
  5. KMNAME="kdepim"
  6. EGIT_BRANCH="KDE/4.14"
  7. inherit kde4-meta
  8. DESCRIPTION="The KDE Address Book"
  9. HOMEPAGE="https://www.kde.org/applications/office/kaddressbook/"
  10. COMMIT_ID="2aec255c6465676404e4694405c153e485e477d9"
  11. SRC_URI="https://quickgit.kde.org/?p=kdepim.git&a=snapshot&h=${COMMIT_ID}&fmt=tgz -> ${KMNAME}-${PV}.tar.gz"
  12. KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
  13. IUSE="debug"
  14. DEPEND="
  15. $(add_kdeapps_dep kdepimlibs 'akonadi(+)')
  16. $(add_kdeapps_dep kdepim-common-libs)
  17. dev-libs/grantlee:0
  18. !kde-base/contactthemeeditor
  19. "
  20. RDEPEND="${DEPEND}"
  21. KMEXTRA="
  22. grantleeeditor/contactthemeeditor
  23. plugins/kaddressbook/
  24. plugins/ktexteditor/
  25. "
  26. KMCOMPILEONLY="
  27. grantleetheme/
  28. kaddressbookgrantlee/
  29. "
  30. KMEXTRACTONLY="
  31. akonadi_next/
  32. calendarsupport/
  33. grantleeeditor/grantleethemeeditor/
  34. libkleo/
  35. pimcommon/
  36. "
  37. KMLOADLIBS="kdepim-common-libs"
  38. pkg_postinst() {
  39. kde4-meta_pkg_postinst
  40. if ! has_version kde-apps/kdepim-kresources:${SLOT}; then
  41. echo
  42. elog "For groupware functionality, please install kde-apps/kdepim-kresources:${SLOT}"
  43. echo
  44. fi
  45. }