kalgebra-16.12.3.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_HANDBOOK="optional"
  5. inherit kde5
  6. DESCRIPTION="MathML-based graph calculator by KDE"
  7. HOMEPAGE="https://www.kde.org/applications/education/kalgebra
  8. https://edu.kde.org/kalgebra"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="opengl readline"
  11. DEPEND="
  12. $(add_frameworks_dep kconfig)
  13. $(add_frameworks_dep kconfigwidgets)
  14. $(add_frameworks_dep kcoreaddons)
  15. $(add_frameworks_dep ki18n)
  16. $(add_frameworks_dep kio)
  17. $(add_frameworks_dep kwidgetsaddons)
  18. $(add_frameworks_dep kxmlgui)
  19. $(add_kdeapps_dep analitza 'opengl?')
  20. $(add_qt_dep qtdeclarative)
  21. $(add_qt_dep qtgui)
  22. $(add_qt_dep qtwebkit)
  23. $(add_qt_dep qtwidgets)
  24. opengl? (
  25. $(add_qt_dep qtopengl)
  26. $(add_qt_dep qtprintsupport)
  27. virtual/glu
  28. )
  29. readline? ( sys-libs/readline:0= )
  30. "
  31. RDEPEND="${DEPEND}
  32. !kde-apps/analitza:4
  33. "
  34. src_configure() {
  35. local mycmakeargs=(
  36. $(cmake-utils_use_find_package opengl OpenGL)
  37. $(cmake-utils_use_find_package readline Readline)
  38. )
  39. kde5_src_configure
  40. }