plasma-telepathy-meta-16.08.3.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit kde5-meta-pkg
  5. DESCRIPTION="Plasma Telepathy client"
  6. HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
  7. LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
  8. KEYWORDS="amd64 x86"
  9. IUSE="gstreamer nls"
  10. [[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
  11. RDEPEND="
  12. $(add_kdeapps_dep ktp-accounts-kcm)
  13. $(add_kdeapps_dep ktp-approver)
  14. $(add_kdeapps_dep ktp-auth-handler)
  15. $(add_kdeapps_dep ktp-common-internals)
  16. $(add_kdeapps_dep ktp-contact-list)
  17. $(add_kdeapps_dep ktp-contact-runner)
  18. $(add_kdeapps_dep ktp-desktop-applets)
  19. $(add_kdeapps_dep ktp-filetransfer-handler)
  20. $(add_kdeapps_dep ktp-kded-module)
  21. $(add_kdeapps_dep ktp-send-file)
  22. $(add_kdeapps_dep ktp-text-ui)
  23. !kde-apps/plasma-telepathy-meta:4
  24. gstreamer? ( $(add_kdeapps_dep ktp-call-ui) )
  25. nls? ( $(add_kdeapps_dep kde-l10n '' ${L10N_MINIMAL}) )
  26. "
  27. pkg_postinst() {
  28. echo
  29. elog "You can configure the accounts in Plasma System Settings"
  30. elog "and then add the Instant Messaging plasma applet to access the contact list."
  31. echo
  32. }