kwayland-5.29.0.ebuild 611 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_TEST="true"
  5. inherit kde5
  6. DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
  7. HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kwayland"
  8. LICENSE="LGPL-2.1"
  9. KEYWORDS="amd64 ~arm x86"
  10. IUSE=""
  11. DEPEND="
  12. $(add_qt_dep qtconcurrent)
  13. $(add_qt_dep qtgui 'egl')
  14. >=dev-libs/wayland-1.7.0
  15. media-libs/mesa[egl]
  16. "
  17. RDEPEND="${DEPEND}
  18. $(add_qt_dep qtwayland 'egl')
  19. !kde-plasma/kwayland
  20. "
  21. # All failing, i guess we need a virtual wayland server
  22. RESTRICT+=" test"