kio-gdrive-1.0.5.ebuild 1022 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_HANDBOOK="true"
  5. inherit kde5
  6. DESCRIPTION="KIO Slave for Google Drive service"
  7. HOMEPAGE="https://phabricator.kde.org/project/profile/72/"
  8. if [[ ${KDE_BUILD_TYPE} != live ]] ; then
  9. SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
  10. KEYWORDS="~amd64"
  11. fi
  12. IUSE="+dolphin"
  13. DOCS=( README.md )
  14. COMMON_DEPEND="
  15. $(add_frameworks_dep ki18n)
  16. $(add_frameworks_dep kio)
  17. $(add_kdeapps_dep libkgapi '' 5.3.1)
  18. $(add_qt_dep qtwidgets)
  19. dev-libs/qtkeychain:=[qt5]
  20. "
  21. DEPEND="${COMMON_DEPEND}
  22. $(add_qt_dep qtgui)
  23. $(add_qt_dep qtnetwork)
  24. "
  25. RDEPEND="${COMMON_DEPEND}
  26. dolphin? ( $(add_kdeapps_dep dolphin) )
  27. "
  28. src_configure() {
  29. local mycmakeargs=(
  30. -DDOLPHIN_INTEGRATION=$(usex dolphin)
  31. )
  32. kde5_src_configure
  33. }
  34. pkg_postinst() {
  35. kde5_pkg_postinst
  36. einfo
  37. einfo "Either click on 'Google Drive File Manager' in the application"
  38. einfo "launcher or type 'gdrive:/' in dolphin's location bar."
  39. einfo
  40. }