lxqt-notificationd-0.10.0.ebuild 740 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="LXQt notification daemon and library"
  6. HOMEPAGE="http://lxqt.org/"
  7. if [[ ${PV} = *9999* ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
  10. else
  11. SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
  12. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  13. fi
  14. LICENSE="GPL-2 LGPL-2.1+"
  15. SLOT="0"
  16. RDEPEND="
  17. >=dev-libs/libqtxdg-1.0.0
  18. dev-qt/qtcore:5
  19. dev-qt/qtdbus:5
  20. dev-qt/qtgui:5
  21. dev-qt/qtwidgets:5
  22. dev-qt/qtx11extras:5
  23. dev-qt/qtxml:5
  24. kde-frameworks/kwindowsystem:5
  25. ~lxqt-base/liblxqt-${PV}
  26. =lxqt-base/lxqt-common-0.10*
  27. "
  28. DEPEND="${RDEPEND}
  29. dev-qt/linguist-tools:5
  30. "