evolution-3.22.4.ebuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit gnome2 flag-o-matic readme.gentoo-r1
  6. DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
  8. # Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
  9. LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
  10. SLOT="2.0"
  11. IUSE="+bogofilter crypt geolocation highlight ldap spamassassin spell ssl +weather"
  12. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
  13. # We need a graphical pinentry frontend to be able to ask for the GPG
  14. # password from inside evolution, bug 160302
  15. PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] app-crypt/pinentry[qt5] )"
  16. # glade-3 support is for maintainers only per configure.ac
  17. # pst is not mature enough and changes API/ABI frequently
  18. # dconf explicitely needed for backup plugin
  19. # gnome-desktop support is optional with --enable-gnome-desktop
  20. # gnome-autoar (currently disabled because no release has been made)
  21. COMMON_DEPEND="
  22. >=app-crypt/gcr-3.4:=
  23. >=app-text/enchant-1.1.7
  24. >=dev-libs/glib-2.46:2[dbus]
  25. >=dev-libs/libxml2-2.7.3:2
  26. >=gnome-base/gnome-desktop-2.91.3:3=
  27. >=gnome-base/gsettings-desktop-schemas-2.91.92
  28. >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
  29. >=media-libs/libcanberra-0.25[gtk3]
  30. >=net-libs/libsoup-2.42:2.4
  31. >=net-libs/webkit-gtk-2.13.90:4
  32. >=x11-libs/cairo-1.9.15:=[glib]
  33. >=x11-libs/gdk-pixbuf-2.24:2
  34. >=x11-libs/gtk+-3.10:3
  35. >=x11-libs/libnotify-0.7:=
  36. >=x11-misc/shared-mime-info-0.22
  37. >=app-text/iso-codes-0.49
  38. dev-libs/atk
  39. gnome-base/dconf
  40. dev-libs/libical:=
  41. x11-libs/libSM
  42. x11-libs/libICE
  43. crypt? (
  44. >=app-crypt/gnupg-1.4
  45. ${PINENTRY_DEPEND}
  46. x11-libs/libcryptui )
  47. geolocation? (
  48. >=media-libs/libchamplain-0.12:0.12[gtk]
  49. >=media-libs/clutter-1.0.0:1.0
  50. >=media-libs/clutter-gtk-0.90:1.0
  51. >=sci-geosciences/geocode-glib-3.10.0
  52. x11-libs/mx:1.0 )
  53. ldap? ( >=net-nds/openldap-2:= )
  54. spell? ( app-text/gtkspell:3 )
  55. ssl? (
  56. >=dev-libs/nspr-4.6.1:=
  57. >=dev-libs/nss-3.11:= )
  58. weather? ( >=dev-libs/libgweather-3.10:2= )
  59. "
  60. DEPEND="${COMMON_DEPEND}
  61. app-text/docbook-xml-dtd:4.1.2
  62. app-text/yelp-tools
  63. >=dev-util/gtk-doc-am-1.14
  64. >=dev-util/intltool-0.40.0
  65. >=gnome-base/gnome-common-2.12
  66. virtual/pkgconfig
  67. "
  68. RDEPEND="${COMMON_DEPEND}
  69. bogofilter? ( mail-filter/bogofilter )
  70. highlight? ( app-text/highlight )
  71. spamassassin? ( mail-filter/spamassassin )
  72. !gnome-extra/evolution-exchange
  73. "
  74. DISABLE_AUTOFORMATTING="yes"
  75. DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
  76. ~/.local/share/applications/mimeapps.list so it includes the
  77. following content:
  78. [Default Applications]
  79. x-scheme-handler/http=firefox.desktop
  80. x-scheme-handler/https=firefox.desktop
  81. (replace firefox.desktop with the name of the appropriate .desktop
  82. file from /usr/share/applications if you use a different browser)."
  83. src_configure() {
  84. # Use NSS/NSPR only if 'ssl' is enabled.
  85. gnome2_src_configure \
  86. --without-glade-catalog \
  87. --disable-autoar \
  88. --disable-code-coverage \
  89. --disable-installed-tests \
  90. --disable-pst-import \
  91. --enable-canberra \
  92. $(use_enable crypt libcryptui) \
  93. $(use_enable highlight text-highlight) \
  94. $(use_enable geolocation contact-maps) \
  95. $(use_enable spell gtkspell) \
  96. $(use_enable ssl nss) \
  97. $(use_enable ssl smime) \
  98. $(use_with bogofilter) \
  99. $(use_with ldap openldap) \
  100. $(use_with spamassassin) \
  101. $(usex ssl --enable-nss=yes "--without-nspr-libs
  102. --without-nspr-includes
  103. --without-nss-libs
  104. --without-nss-includes") \
  105. $(use_enable weather)
  106. }
  107. src_install() {
  108. gnome2_src_install
  109. # Problems with prelink:
  110. # https://bugzilla.gnome.org/show_bug.cgi?id=731680
  111. # https://bugzilla.gnome.org/show_bug.cgi?id=732148
  112. # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
  113. echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
  114. doenvd "${T}"/99${PN}
  115. readme.gentoo_create_doc
  116. }
  117. pkg_postinst() {
  118. gnome2_pkg_postinst
  119. readme.gentoo_print_elog
  120. }