displaycal-3.2.2.0.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1 xdg
  6. MY_PN="DisplayCAL"
  7. MY_P="${MY_PN}-${PV}"
  8. DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
  9. HOMEPAGE="https://displaycal.net/"
  10. SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. DEPEND="
  16. >=media-gfx/argyllcms-1.1.0
  17. dev-python/wxpython:3.0
  18. >=x11-libs/libX11-1.3.3
  19. >=x11-apps/xrandr-1.3.2
  20. >=x11-libs/libXxf86vm-1.1.0
  21. >=x11-proto/xineramaproto-1.2
  22. >=x11-libs/libXinerama-1.1
  23. "
  24. RDEPEND="${DEPEND}
  25. >=dev-python/numpy-1.2.1
  26. "
  27. # Just in case someone renames the ebuild
  28. S="${WORKDIR}/${MY_P}"
  29. src_prepare() {
  30. # Do not generate udev/hotplug files
  31. sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
  32. -i DisplayCAL/setup.py || die
  33. # Prohibit setup from running xdg-* programs, resulting to sandbox violation
  34. sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
  35. -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
  36. -i DisplayCAL/postinstall.py || die
  37. # Remove deprecated Encoding key from .desktop file
  38. sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
  39. # Remove x-world Media Type
  40. sed -e 's/x\-world\/x\-vrml\;//g' \
  41. -i misc/displaycal-vrml-to-x3d-converter.desktop || die
  42. distutils-r1_src_prepare
  43. }