postr-0.13.1.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. PYTHON_COMPAT=( python2_7 )
  6. PYTHON_REQ_USE="xml"
  7. inherit eutils gnome2 python-single-r1
  8. DESCRIPTION="Flickr uploader for GNOME"
  9. HOMEPAGE="https://wiki.gnome.org/Apps/Postr"
  10. LICENSE="GPL-2+ CC-BY-SA-3.0"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE=""
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. COMMON_DEPEND="
  16. ${PYTHON_DEPS}
  17. dev-python/pygtk:2[${PYTHON_USEDEP}]
  18. "
  19. RDEPEND="${COMMON_DEPEND}
  20. dev-python/bsddb3[${PYTHON_USEDEP}]
  21. dev-python/dbus-python[${PYTHON_USEDEP}]
  22. dev-python/gconf-python[${PYTHON_USEDEP}]
  23. dev-python/gtkspell-python[${PYTHON_USEDEP}]
  24. dev-python/libgnome-python[${PYTHON_USEDEP}]
  25. dev-python/pygobject:2[${PYTHON_USEDEP}]
  26. dev-python/twisted-core[${PYTHON_USEDEP}]
  27. dev-python/twisted-web[${PYTHON_USEDEP}]
  28. "
  29. DEPEND="${COMMON_DEPEND}
  30. app-text/gnome-doc-utils
  31. dev-util/intltool
  32. sys-devel/gettext
  33. virtual/pkgconfig"
  34. src_prepare() {
  35. # Don't check for nautilus-python if we aren't installing the nautilus-2 extension
  36. sed -e 's:nautilus-python >= 0.6.1::' -i configure || die
  37. gnome2_src_prepare
  38. }
  39. src_configure() {
  40. gnome2_src_configure \
  41. --with-nautilus-extension-dir="${EPREFIX}"/usr/share/nautilus-python/extensions
  42. }
  43. src_install() {
  44. gnome2_src_install
  45. python_fix_shebang "${ED}"
  46. rm -r "${ED}usr/share/nautilus-python" || die
  47. }