pstoedit-3.70-r1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
  6. HOMEPAGE="https://sourceforge.net/projects/pstoedit/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="emf flash imagemagick plotutils pptx static-libs"
  12. RDEPEND="
  13. >=media-libs/gd-2.0.35-r1:=
  14. >=app-text/ghostscript-gpl-8.71-r1
  15. emf? ( >=media-libs/libemf-1.0.3 )
  16. flash? ( >=media-libs/ming-0.4.3 )
  17. imagemagick? ( >=media-gfx/imagemagick-6.6.1.2[cxx] )
  18. plotutils? ( media-libs/plotutils )
  19. pptx? ( dev-libs/libzip )
  20. "
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig
  23. "
  24. PATCHES=(
  25. "${FILESDIR}"/${PN}-3.60-libdl.patch
  26. "${FILESDIR}"/${PN}-3.70-pkgconfig.patch
  27. )
  28. src_prepare() {
  29. default
  30. sed -i \
  31. -e '/CXXFLAGS="-g"/d' \
  32. -e 's:-pedantic::' \
  33. configure.ac || die
  34. eautoreconf
  35. }
  36. src_configure() {
  37. econf \
  38. $(use_enable static-libs static) \
  39. $(use_with emf) \
  40. $(use_with imagemagick magick) \
  41. $(use_with plotutils libplot) \
  42. $(use_with flash swf) \
  43. $(use_with pptx)
  44. }
  45. src_install() {
  46. default
  47. doman doc/pstoedit.1
  48. dodoc doc/*.txt
  49. docinto html
  50. dodoc doc/*.htm
  51. find "${ED}" -name '*.la' -delete
  52. }