libde265-0.9.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. AUTOTOOLS_AUTORECONF=1
  6. inherit autotools-multilib
  7. DESCRIPTION="Open h.265 video codec implementation"
  8. HOMEPAGE="https://github.com/strukturag/libde265"
  9. SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
  14. DEPEND="
  15. qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
  16. qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
  17. media-libs/libsdl
  18. virtual/ffmpeg
  19. "
  20. RDEPEND="${DEPEND}"
  21. REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
  22. src_configure() {
  23. local myeconfargs=(
  24. $(use_enable cpu_flags_x86_sse sse)
  25. $(use_enable static-libs static)
  26. $(use_enable debug log-info)
  27. $(use_enable debug log-debug)
  28. $(use_enable debug log-trace)
  29. $(use_enable tools dec265)
  30. $(use_enable tools sherlock265)
  31. --disable-silent-rules
  32. --enable-log-error
  33. )
  34. autotools-multilib_src_configure "${myeconfargs[@]}"
  35. }