libde265-1.0.2.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. AUTOTOOLS_AUTORECONF=1
  6. inherit autotools-multilib
  7. DESCRIPTION="Open h.265 video codec implementation"
  8. HOMEPAGE="https://github.com/strukturag/libde265"
  9. SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
  14. DEPEND="
  15. qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
  16. qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
  17. media-libs/libsdl
  18. virtual/ffmpeg
  19. "
  20. RDEPEND="${DEPEND}"
  21. REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
  22. src_prepare() {
  23. sed -ri 's/(PIX_FMT_)/AV_\1/g' sherlock265/VideoDecoder.cc || die
  24. autotools-multilib_src_prepare
  25. }
  26. src_configure() {
  27. local myeconfargs=(
  28. $(use_enable cpu_flags_x86_sse sse)
  29. $(use_enable static-libs static)
  30. $(use_enable debug log-info)
  31. $(use_enable debug log-debug)
  32. $(use_enable debug log-trace)
  33. $(use_enable tools dec265)
  34. $(use_enable tools sherlock265)
  35. --disable-silent-rules
  36. --enable-log-error
  37. )
  38. autotools-multilib_src_configure "${myeconfargs[@]}"
  39. }