libvisio-9999.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
  5. [[ ${PV} == 9999 ]] && inherit autotools git-r3
  6. DESCRIPTION="Library parsing the visio documents"
  7. HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
  8. [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
  9. LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
  10. SLOT="0"
  11. [[ ${PV} == 9999 ]] || \
  12. KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
  13. IUSE="doc static-libs test tools"
  14. RDEPEND="
  15. dev-libs/icu:=
  16. dev-libs/librevenge
  17. dev-libs/libxml2
  18. sys-libs/zlib
  19. "
  20. DEPEND="${RDEPEND}
  21. dev-lang/perl
  22. dev-libs/boost
  23. dev-util/gperf
  24. sys-devel/libtool
  25. virtual/pkgconfig
  26. doc? ( app-doc/doxygen )
  27. test? ( dev-util/cppunit )
  28. "
  29. src_prepare() {
  30. default
  31. [[ -d m4 ]] || mkdir "m4"
  32. [[ ${PV} == 9999 ]] && eautoreconf
  33. }
  34. src_configure() {
  35. econf \
  36. --disable-werror \
  37. $(use_with doc docs) \
  38. $(use_enable static-libs static) \
  39. $(use_enable test tests) \
  40. $(use_enable tools)
  41. }
  42. src_install() {
  43. default
  44. find "${D}" -name '*.la' -delete || die
  45. }