libvorbis-1.3.3-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. inherit autotools-multilib
  6. DESCRIPTION="The Ogg Vorbis sound file format library"
  7. HOMEPAGE="http://xiph.org/vorbis"
  8. SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.xz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  12. IUSE="static-libs"
  13. RDEPEND=">=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
  14. abi_x86_32? ( !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
  15. DEPEND="${RDEPEND}
  16. app-arch/xz-utils
  17. virtual/pkgconfig"
  18. AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
  19. src_prepare() {
  20. sed -i \
  21. -e '/CFLAGS/s:-O20::' \
  22. -e '/CFLAGS/s:-mcpu=750::' \
  23. -e '/CFLAGS/s:-mno-ieee-fp::' \
  24. -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
  25. configure.ac || die
  26. # Un-hack docdir redefinition.
  27. find -name 'Makefile.am' \
  28. -exec sed -i \
  29. -e 's:$(datadir)/doc/$(PACKAGE)-$(VERSION):@docdir@/html:' \
  30. {} + || die
  31. AT_M4DIR="m4" \
  32. autotools-multilib_src_prepare
  33. }