libzen-0.4.35.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools multilib eutils
  5. MY_PN="ZenLib"
  6. DESCRIPTION="Shared library for libmediainfo and mediainfo"
  7. HOMEPAGE="https://github.com/MediaArea/ZenLib http://mediaarea.net/mediainfo/"
  8. SRC_URI="http://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.bz2"
  9. LICENSE="ZLIB"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc static-libs"
  13. DEPEND="virtual/pkgconfig
  14. doc? ( app-doc/doxygen )"
  15. S=${WORKDIR}/${MY_PN}/Project/GNU/Library
  16. src_prepare() {
  17. default
  18. sed -i 's:-O2::' configure.ac || die
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. --enable-unicode \
  24. --enable-shared \
  25. $(use_enable static-libs static)
  26. }
  27. src_compile() {
  28. default
  29. if use doc ; then
  30. cd "${WORKDIR}"/${MY_PN}/Source/Doc
  31. doxygen Doxyfile || die
  32. fi
  33. }
  34. src_install() {
  35. default
  36. # remove since the pkgconfig file should be used instead
  37. rm "${D}"/usr/bin/libzen-config
  38. insinto /usr/$(get_libdir)/pkgconfig
  39. doins ${PN}.pc
  40. for x in ./ Format/Html Format/Http HTTP_Client ; do
  41. insinto /usr/include/${MY_PN}/${x}
  42. doins "${WORKDIR}"/${MY_PN}/Source/${MY_PN}/${x}/*.h
  43. done
  44. dodoc "${WORKDIR}"/${MY_PN}/History.txt
  45. if use doc ; then
  46. docinto html
  47. dodoc "${WORKDIR}"/${MY_PN}/Doc/*
  48. fi
  49. prune_libtool_files
  50. }