lv2-1.10.0-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE='threads(+)'
  6. inherit python-single-r1 waf-utils
  7. DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
  8. HOMEPAGE="http://lv2plug.in/"
  9. SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc ~ppc64 x86"
  13. IUSE="doc plugins"
  14. DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
  15. RDEPEND="${DEPEND}
  16. dev-python/lxml[${PYTHON_USEDEP}]
  17. dev-python/pygments[${PYTHON_USEDEP}]
  18. dev-python/rdflib[${PYTHON_USEDEP}]
  19. !<media-libs/slv2-0.4.2
  20. !media-libs/lv2core
  21. !media-libs/lv2-ui"
  22. DEPEND="${DEPEND}
  23. plugins? ( virtual/pkgconfig )
  24. doc? ( app-doc/doxygen dev-python/rdflib )"
  25. DOCS=( "README" "NEWS" )
  26. src_configure() {
  27. waf-utils_src_configure \
  28. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  29. $(use plugins || echo " --no-plugins") \
  30. $(use doc && echo " --docs" )
  31. }
  32. src_install() {
  33. waf-utils_src_install
  34. python_fix_shebang "${D}"
  35. }