sdl-net-1.2.8-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib-minimal
  5. MY_P=${P/sdl-/SDL_}
  6. DESCRIPTION="Simple Direct Media Layer Network Support Library"
  7. HOMEPAGE="http://www.libsdl.org/projects/SDL_net/index.html"
  8. SRC_URI="http://www.libsdl.org/projects/SDL_net/release/${MY_P}.tar.gz"
  9. LICENSE="ZLIB"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  12. IUSE="static-libs"
  13. RDEPEND="
  14. abi_x86_32? (
  15. !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
  16. !<=app-emulation/emul-linux-x86-sdl-20140406
  17. )
  18. >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]"
  19. DEPEND="${RDEPEND}"
  20. S=${WORKDIR}/${MY_P}
  21. multilib_src_configure() {
  22. ECONF_SOURCE="${S}" econf \
  23. --disable-dependency-tracking \
  24. --disable-gui \
  25. $(use_enable static-libs static)
  26. }
  27. multilib_src_install() {
  28. emake DESTDIR="${D}" install
  29. }
  30. multilib_src_install_all() {
  31. dodoc CHANGES README
  32. if ! use static-libs ; then
  33. find "${D}" -type f -name '*.la' -exec rm {} + \
  34. || die "la removal failed"
  35. fi
  36. }