sratom-0.4.6.ebuild 962 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. PYTHON_REQ_USE='threads(+)'
  6. inherit python-any-r1 waf-utils
  7. DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
  8. HOMEPAGE="http://drobilla.net/software/sratom/"
  9. SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
  10. LICENSE="ISC"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~ppc x86"
  13. IUSE="doc static-libs test"
  14. RDEPEND=">=media-libs/lv2-1.8.1
  15. >=dev-libs/serd-0.14.0
  16. >=dev-libs/sord-0.12.0"
  17. DEPEND="${RDEPEND}
  18. ${PYTHON_DEPS}
  19. doc? ( app-doc/doxygen )
  20. virtual/pkgconfig"
  21. DOCS=( "NEWS" "README" )
  22. src_prepare() {
  23. sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
  24. }
  25. src_configure() {
  26. waf-utils_src_configure \
  27. --docdir=/usr/share/doc/${PF} \
  28. $(use test && echo "--test") \
  29. $(use doc && echo "--docs") \
  30. $(use static-libs && echo "--static")
  31. }
  32. src_test() {
  33. ./waf test || die
  34. }