libva-utils-1.8.0.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. SCM=""
  5. if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
  6. SCM=git-r3
  7. EGIT_BRANCH=master
  8. EGIT_REPO_URI="https://github.com/01org/libva-utils"
  9. fi
  10. AUTOTOOLS_AUTORECONF="yes"
  11. inherit autotools-utils ${SCM} multilib
  12. DESCRIPTION="Collection of utilities and tests for VA-API"
  13. HOMEPAGE="https://01.org/linuxmedia/vaapi"
  14. if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
  15. SRC_URI=""
  16. else
  17. SRC_URI="https://github.com/01org/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
  18. fi
  19. LICENSE="MIT"
  20. SLOT="0"
  21. if [ "${PV%9999}" = "${PV}" ] ; then
  22. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  23. else
  24. KEYWORDS=""
  25. fi
  26. IUSE="+drm test wayland X"
  27. RDEPEND="
  28. >=x11-libs/libva-1.8[drm?,wayland?,X?]
  29. drm? ( >=x11-libs/libdrm-2.4 )
  30. X? (
  31. >=x11-libs/libX11-1.6.2
  32. >=x11-libs/libXext-1.3.2
  33. >=x11-libs/libXfixes-5.0.1
  34. )
  35. wayland? ( >=dev-libs/wayland-1.0.6 )"
  36. DEPEND="${RDEPEND}
  37. virtual/pkgconfig"
  38. REQUIRED_USE="|| ( drm wayland X )"
  39. DOCS=( CONTRIBUTING.md README.md )
  40. src_configure() {
  41. local myeconfargs=(
  42. $(use_enable X x11)
  43. $(use_enable wayland)
  44. $(use_enable drm)
  45. $(use_enable test tests)
  46. )
  47. autotools-utils_src_configure
  48. }