parole-0.8.0-r1.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="a simple media player based on the GStreamer framework for the Xfce4 desktop"
  6. HOMEPAGE="http://goodies.xfce.org/projects/applications/parole/"
  7. SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~mips x86"
  11. IUSE="clutter debug libnotify taglib"
  12. COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
  13. >=dev-libs/glib-2.32:2=
  14. media-libs/gstreamer:1.0=
  15. media-libs/gst-plugins-base:1.0=
  16. sys-apps/dbus:0=
  17. >=x11-libs/gtk+-3.2:3=
  18. x11-libs/libX11:0=
  19. >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
  20. >=xfce-base/libxfce4util-4.11:0=
  21. >=xfce-base/xfconf-4.10:0=
  22. clutter? (
  23. >=media-libs/clutter-1.16.4:1.0=
  24. >=media-libs/clutter-gtk-1.4.4:1.0=
  25. )
  26. libnotify? ( >=x11-libs/libnotify-0.7:0= )
  27. taglib? ( >=media-libs/taglib-1.6:0= )"
  28. RDEPEND="${COMMON_DEPEND}
  29. media-plugins/gst-plugins-meta:1.0"
  30. DEPEND="${COMMON_DEPEND}
  31. dev-util/intltool
  32. sys-devel/gettext
  33. virtual/pkgconfig
  34. x11-proto/xproto"
  35. pkg_setup() {
  36. XFCONF=(
  37. $(use_enable clutter)
  38. $(use_enable taglib)
  39. $(use_enable libnotify notify-plugin)
  40. $(xfconf_use_debug)
  41. --with-gstreamer=1.0
  42. )
  43. DOCS=( AUTHORS ChangeLog README THANKS TODO )
  44. }