shrip-0.6.0.ebuild 793 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. DESCRIPTION="Command line tool for ripping DVDs and encoding to AVI/OGM/MKV/MP4"
  5. HOMEPAGE="http://ogmrip.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/ogmrip/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="nls"
  11. RDEPEND=">=dev-libs/glib-2.14:2
  12. >=media-video/ogmrip-0.13.4"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. nls? ( dev-util/intltool
  16. sys-devel/gettext )"
  17. src_prepare() {
  18. sed -i \
  19. -e '/CFLAGS/s:-Werror::' \
  20. configure || die
  21. }
  22. src_configure() {
  23. econf \
  24. --disable-dependency-tracking \
  25. $(use_enable nls)
  26. }
  27. src_install() {
  28. emake DESTDIR="${D}" install || die
  29. dodoc AUTHORS ChangeLog README TODO
  30. insinto /etc
  31. doins shrip.conf || die
  32. }