snappy-1.0-r1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG="no"
  5. inherit autotools eutils gnome2
  6. DESCRIPTION="A simple media player written using GStreamer and Clutter"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Snappy"
  8. KEYWORDS="amd64 x86"
  9. LICENSE="GPL-2 LGPL-2"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. >=dev-libs/glib-2.32:2
  14. >=media-libs/clutter-1.20.0:1.0
  15. media-libs/clutter-gst:3.0
  16. >=media-libs/clutter-gtk-1.6.0:1.0
  17. >=x11-libs/gtk+-3.5.0:3
  18. x11-libs/libXtst
  19. >=media-libs/gstreamer-1.4.0:1.0
  20. >=media-libs/gst-plugins-base-1.4.0:1.0
  21. media-plugins/gst-plugins-meta:1.0
  22. !!<net-misc/spice-gtk-0.19
  23. " # File collision -- /usr/bin/snappy with older versions
  24. DEPEND="${RDEPEND}"
  25. src_prepare() {
  26. # Fix compat with clutter-1.22 (from 'master')
  27. epatch "${FILESDIR}"/${P}-clutter-1.22.patch
  28. # ui: string concatenation to use corect format (from 'master')
  29. epatch "${FILESDIR}"/${P}-string-concatenation.patch
  30. # clutter: update method to create video texture (from 'master')
  31. epatch "${FILESDIR}"/${P}-video-texture.patch
  32. # Move to clutter-gst-3 (from 'master')
  33. epatch "${FILESDIR}"/${P}-configure{1,2}.patch
  34. epatch "${FILESDIR}"/${P}-clutter-gst-3.patch
  35. eautoreconf
  36. gnome2_src_prepare
  37. }
  38. src_configure() {
  39. DOCS="AUTHORS README THANKS ToDo docs/*"
  40. gnome2_src_configure --enable-dbus
  41. }